Thema: Keine working Server

Forum: Linux-Server

Autor: Na_Mi


Na_Mi - 5/2/2003 um 19:40

Hallo
Hab mal wieder ein kleines Problem und zwar habe ich keine working Server mehr in meiner ServerListe. Hab die schon mehrfach neu runtergeladen, aber es tut sich einfach nix. Nach einer gewissen Zeit leert sich die ServerListe auch, bis keine Server mehr drin stehen. Habe auch schon mehrer Seed Server gestestet leider ohne Erfolg.

Na_Mi

MetWURST - 5/2/2003 um 20:03

Hi,

stell mal den Inhalt Deiner donkey.ini hier rein.
Werd mal sehen.

Gruß aus Sachsen :)

Na_Mi - 5/2/2003 um 20:20

Also die sollte gehen, weil das bis vor ein par Tagen ja noch geklappt hat. Und an denn Einstellungen hab ich nix geändert, außerhalt Seed Server und die Userzahl. :yltype:

MetWURST - 5/2/2003 um 20:31

Versuch mal die seed-IP von dem Client mit dem Du gerade verbunden bist. D.h. eMule starten und die IP des verbundenen Servers nehmen.

Na_Mi - 5/2/2003 um 21:11

Also ich habe eigentlich alle großen Server ausprobiert, leider geht keiner von dennen. Ich weiß nicht was es sein könnte. Aktuell hab ich in der ServerListe 316 Server drin stehen, abe unter working ist nix, null. Laut der Severliste hab ich Refs = 0 und known = 4 .

Na_Mi

MetWURST - 5/2/2003 um 21:21

und du hast keinen Schreibfehler in der donkey.ini ??

Na_Mi - 5/2/2003 um 21:39

# donkey.ini schreiben
echo "[server]
name=Na_Mi's Lugdunix
desc=www.Fetter-Esel.de
thisIP=$4
thisPort=4661
seedIP=193.111.198.139
seedPort=4242
maxClients=1200
threads=40
tableSize=3089
minVersion=59
maxVersion=61
public=true
type=key
console=true
welcome[0]=
welcome[1]= Willkommen auf Na_Mi's Lugdunix!
welcome[2]=
welcome[3]= 1200 User
welcome[4]=
welcome[5]= www.Fetter-Esel.de
welcome[6]=

filter[0]=(#FILENAME .part)
filter[1]=(#FILENAME .dll)
filter[2]=(#FILENAME .met)
filter[3]=(#FILENAME .sys)
filter[4]=(#FILENAME .lnk)

" > /root/dserver/donkey.ini

# dserver starten
sleep 1
cd /root/dserver
screen -d -m dserver

# QoS einschalten
/root/qos-on

# dserver mit nbuser einstellen
sleep 1
nbuser -l 1 #Connect von Low-ID-Clients erlauben
nbuser -B 0 #Connect von BOT-Clients verbieten
nbuser -Z 1 #Connect von MLDonkeys verbieten
nbuser -s 10000 #Das ?Soft-Limit? an maximal erlaubten Dateien. Alle überzähligen Dateien werden weggelassen
nbuser -D 40000 #Das ?Hard-Limit? an maximal erlaubten Dateien. Clients mit mehr Dateien werden gekickt
nbuser -S 1440 #Zeit zwischen Server-Aktualisierungen
nbuser -R 50 #Max. Low-ID-Clients in Prozent


das ist die komplette datei, bzw der auszug auf der ip-up

Na_Mi

MetWURST - 5/2/2003 um 21:50

ich weiß zwar nicht ob's daran liegt; aber warum benutzt Du nicht seedPort=4711 ?? :question:

IhmSelbst - 5/2/2003 um 22:27

Bei SeedPort ist der Port des Seedservers einzutragen. Sollte der "Seed-Server" einen anderen Port als den üblichen Port TCP:4661 benutzen, muß dieser hier angegeben werden. Über 90% aller Server benutzen Port 4661.
4242 ist der von SilentBob. Allerdings äffen die Probenprinzen den auch nach.

Sollte nicht noch ein udp-Problem vorliegen, kannst die Seed-Einträge auch weglassen, sofern eine aktuelle serverList.met existiert.

cu

MetWURST - 5/2/2003 um 22:53

das könnte es sein, Du mußt den seedPort=.... nehmen, der zur seedIP gehört

Na_Mi - 5/2/2003 um 22:56

Tja ich hatte ja schon gesagt, das ich die großen ausprobiert habe, Silent Bob auch und zurzeit hab ich die Donkey No3 drin und der läuft ja auf 4242. Und ich habe auch eine aktuelle Server.met drin. Nur jetzt habe ich auch known = 0 in der Serverliste. Ist doch alles sehr merkwürdig??? ;(

Na_Mi

[Editiert am 5/2/2003 von Na_Mi]

MetWURST - 5/2/2003 um 23:15

versuchs mal mit meinem:

217.232.107.250 port:4661

IhmSelbst - 5/2/2003 um 23:22


Zitat:
Und ich habe auch eine aktuelle Server.met drin. Nur jetzt habe ich auch known = 0 in der Serverliste. Ist doch alles sehr merkwürdig???


umbenannt in serverList.met?

cu

MetWURST - 5/2/2003 um 23:30

Laut der Severliste hab ich Refs = 0 und known = 4 .(Topic weiter oben)

Könnte er die sonst lesen??

IhmSelbst - 6/2/2003 um 00:23


Zitat:
Laut der Severliste hab ich Refs = 0 und known = 4 .(Topic weiter oben)
Könnte er die sonst lesen??

Hehe, wie Du schon sagst, Posting weiter oben, aber:
Zitat:
... Nur jetzt habe ich auch known = 0 in der Serverliste. ...

Posting weiter unten. ;)

cu

Sucarab - 6/2/2003 um 01:02

...wenn Du eine frische serverList.met benutzt und trotzdem keine working Server bekommst, solltest Du mal überprüfen ob
- Dein UDP-Port erreichbar ist und
- ob Du nicht versehentlich (vielleicht mit dem nbuser-Befehl) den server non-public schaltest.

ganzneu - 6/2/2003 um 03:39

hi na_mi,

also ich denk mal da läuft der dserver zweimal bei dir.

mach mal:
killall dserver &
killall -9 dserver
killall -9 screen

dann am besten seedIP und seedport in der *.ini löschen.
ist ein relikt aus grauen vorzeiten und nicht mehr nötig in heutigen zeiten.
hole dir ne aktuelle server.met bei: firstsense.
die umbenennen in serverList.met und starte alles neu.

neuxxxxx

chemot - 6/2/2003 um 08:51

hallo@all
-----------------------------
donkey.ini schreiben
echo "[server]
name=Na_Mi's Lugdunix
desc=www.Fetter-Esel.de
thisIP=$4
thisPort=4661=======kommt da nicht einfach nur Port hin??
......................

Sucarab - 6/2/2003 um 11:14


Zitat:
hallo@all

thisPort=4661=======kommt da nicht einfach nur Port hin??
......................


Ja, eigentlich schon.
Da es sich hier jedoch um den Standard-Port 4661 handelt wird es wohl egal sein - man könnte den Eintrag rein theoretisch auch ganz weg lassen.

[Editiert am 6/2/2003 von Sucarab]

Na_Mi - 6/2/2003 um 18:47

Also um dem ganzen schon mal vorzubeugen ich habe die Server.met in SeverList.met umbenannt.


Zitat:
... Nur jetzt habe ich auch known = 0 in der Serverliste. ...



Das war kurz nach Server Neustart.


Zitat:
Laut der Severliste hab ich Refs = 0 und known = 4 .(Topic weiter oben)
Könnte er die sonst lesen??



Das war dann kurze Zeit später.
Als ich heute morgen vor der Arbeit reingeschaut habe, hatte ich gar keine Server mehr drin. Aber fast 1200 User auf dem Server.

Und wenn ich denn Server über den nbuser Befehl ja non public schalten würde, sollte der ja auch in keiner Serverliste auftauchen.

Und ich mußte den Rechner auch schon mehrmals neustarten, als schließe ich den zweiten Server mal aus, ob wohl zuletzt ein Bekannter meinte ich hätte zwei Server laufen.

So ich habe mir die Serverliste runtergeladen und es tut sich noch nix. 322 Server davon 0 working.
Welchen UDP Port muß ich denn haben ???


Na_Mi

IhmSelbst - 6/2/2003 um 20:41


Zitat:
Welchen UDP Port muß ich denn haben ???


Vier höher als TCP. Also bei TCP 4661 udp 4665.

cu

BTW:
Das mit dem "thisPort" ist ein Bug im Image, und kann hier nachgelesen werden.

cu

Na_Mi - 12/2/2003 um 21:36

Also ich habe noch was weiter rum versucht, aber es hatte sich nix getan. Dann habe ich denn Firewall mal gelöscht und von hier runterkopiert und siehe da es geht wieder. Aber warum und wie so das vorher nicht ging weiß ich leider nicht.

Na_Mi

easy312 - 24/2/2003 um 20:44

Falls es nochmal auftritt musst du in der susefirewall2.cfg unter punkt 14 dieses ersetzten.

FW_FORWARD_MASQ="0/0,192.168.0.2,tcp,4662 0/0,192.168.0.2,udp,7777:7781"


Dieser Fall tritt auf wenn du versuchst in der ip-up den seedport änderst und er nicht 4661 lautet und/oder du diese Zeile veränderst

Habe auch lange gesucht und probiert.

Gruss

Dieses Thema kommt von : eD2K-Serverboard
http://ed2k-serverboard.de

URL dieser Webseite:
http://ed2k-serverboard.de/modules.php?name=eBoard&file=viewthread&fid=2&tid=114